summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-31 05:35:30 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-06 22:11:49 +0200
commit12c3e3341d5d4a3a98c5f6ebe7166034bd025a45 (patch)
tree7f08dd2bcab2a66b050d9e548bfef7af6eea80fd /gnu/packages/gnome.scm
parent9c28ee9daf0927905916e2102830b958b20a164c (diff)
gnu: gnome-shell: Update to 44.3.
* gnu/packages/gnome.scm (gnome-shell): Update to 44.3. [arguments]<#:phases>: Add ‘unbreak-perf-tests’. Adjust ‘pre-check’ accordingly. [native-inputs]: Add python-dbus and python-dbusmock. [inputs]: Remove caribou. Replace gcr-3 with gcr.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81e3e0cd65..5c0f84d057 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9113,7 +9113,7 @@ properties, screen resolution, and other GNOME parameters.")
(define-public gnome-shell
(package
(name "gnome-shell")
- (version "42.4")
+ (version "44.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -9121,7 +9121,7 @@ properties, screen resolution, and other GNOME parameters.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0kn5fclciybp2fs38wd39hdz85y91pas0ckfa02pmyx91sbz4pw7"))))
+ "1grizh3fbks5dgizaj38300cz97ay81q0hlk1pvawkpfq9qlnsam"))))
(build-system meson-build-system)
(arguments
(let ((disallowed-references
@@ -9159,6 +9159,12 @@ properties, screen resolution, and other GNOME parameters.")
(substitute* "meson.build"
(("gtk_update_icon_cache: true")
"gtk_update_icon_cache: false"))))
+ (add-after 'unpack 'unbreak-perf-tests
+ (lambda _
+ ;; Lest non-fatal dbus warnings be made fatal again…
+ (substitute* "tests/meson.build"
+ (("perf_testenv\\.set\\('G_DEBUG'" all)
+ (string-append "# " all)))))
(add-before 'configure 'record-absolute-file-names
(lambda* (#:key inputs #:allow-other-keys)
(let ((ibus-daemon (search-input-file inputs "bin/ibus-daemon"))
@@ -9175,7 +9181,13 @@ properties, screen resolution, and other GNOME parameters.")
;; Tests require a running X server.
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
- (setenv "HOME" "/tmp"))) ;to avoid "fatal" warnings
+ ;; For the missing /var/lib/dbus/machine-id
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (setenv "NO_AT_BRIDGE" "1")
+ (setenv "HOME" "/tmp")
+ (setenv "XDG_RUNTIME_DIR" (string-append (getcwd) "/runtime-dir"))
+ (mkdir (getenv "XDG_RUNTIME_DIR"))
+ (chmod (getenv "XDG_RUNTIME_DIR") #o700)))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs #:allow-other-keys)
(let ((gi-typelib-path (getenv "GI_TYPELIB_PATH"))
@@ -9241,16 +9253,17 @@ printf '~a is deprecated. Use the \"gnome-extensions\" CLI or \
perl
pkg-config
python
+ python-dbus
+ python-dbusmock
ruby-sass
sassc
;; For tests
xorg-server-for-tests))
(inputs
(list accountsservice
- caribou
docbook-xsl
evolution-data-server
- gcr-3
+ gcr
gdm
librsvg
gjs