summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-12 10:21:23 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-13 20:37:35 +0200
commit1468bf8db5f1ab65e0f8c44a2be2cdb370de1dca (patch)
tree9bc09a3d12edfe95d680fbe0ffa309e7f2cef737 /gnu/packages/gnome.scm
parent9f04e180654494c850be5200ddce6fa6e9067b6d (diff)
gnu: gnome-mahjongg: Update to 3.40.0.
* gnu/packages/gnome.scm (gnome-mahjongg): Update to 3.40.0.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm68
1 files changed, 32 insertions, 36 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d17100b999..5b4059f52e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12161,44 +12161,40 @@ library which detects when a file or a directory has been modified.")
(license license:gpl2+)))
(define-public gnome-mahjongg
- ;; There hasn't been a GNOME Mahjongg release in a long time, and the last
- ;; release doesn't build with a recent Meson, so use the latest commit.
- (let ((commit "e9e73e5165e5968ff897e568f8eba10fc1eb207b")
- (revision "0"))
- (package
- (name "gnome-mahjongg")
- (version (git-version "3.38.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.gnome.org/GNOME/gnome-mahjongg")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1cj0c076h7qfz77wpz8ypli60inj37fgw0cl9cc39b1kjfqcy3mb"))))
- (build-system meson-build-system)
- (arguments (list #:glib-or-gtk? #t))
- (native-inputs
- (list appstream-glib
- gettext-minimal
- `(,glib "bin") ;for glib-compile-resources
- `(,gtk "bin") ;for gtk-update-icon-cache
- itstool
- pkg-config
- vala))
- (propagated-inputs
- (list dconf))
- (inputs
- (list glib
- gtk
- libadwaita))
- (synopsis "Mahjongg tile-matching game")
- (description "GNOME Mahjongg is a game based on the classic Chinese
+ (package
+ (name "gnome-mahjongg")
+ (version "3.40.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/gnome-mahjongg")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yj41lj2vancjzwjcm5cdv48983jq05i6sw8p4nggyqwij3xpllj"))))
+ (build-system meson-build-system)
+ (arguments (list #:glib-or-gtk? #t))
+ (native-inputs
+ (list appstream-glib
+ gettext-minimal
+ `(,glib "bin") ;for glib-compile-resources
+ `(,gtk "bin") ;for gtk-update-icon-cache
+ itstool
+ pkg-config
+ vala))
+ (propagated-inputs
+ (list dconf))
+ (inputs
+ (list glib
+ gtk
+ libadwaita))
+ (synopsis "Mahjongg tile-matching game")
+ (description "GNOME Mahjongg is a game based on the classic Chinese
tile-matching game Mahjongg. It features multiple board layouts, tile themes,
and a high score table.")
- (home-page "https://wiki.gnome.org/Apps/Mahjongg")
- (license license:gpl2+))))
+ (home-page "https://wiki.gnome.org/Apps/Mahjongg")
+ (license license:gpl2+)))
(define-public gnome-themes-extra
(package