summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-29 10:59:07 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-06 23:19:12 -0400
commit1573dffd2b34b896f068950284c191f28a7ca2a4 (patch)
treecb2b81f7b00e97c41f99df46d088ae14c22b69e6 /gnu/packages/gnome.scm
parent5dcfe798f44753e18104541e83591cac6e053525 (diff)
libnma: Update to 1.10.6.
Fixes <https://issues.guix.gnu.org/62496> and <https://issues.guix.gnu.org/63154>. * gnu/packages/gnome.scm (libnma): Update to 1.10.6. Also remove general schema that belongs to network-manager-applet. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3d49ec3de5..854b17672a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1735,7 +1735,7 @@ client devices can handle.")
(define-public libnma
(package
(name "libnma")
- (version "1.10.2")
+ (version "1.10.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1743,14 +1743,26 @@ client devices can handle.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0h095a26w3sgbspsf7wzz8ddg62j3jb9ckrrv41k7cdp0k2dkhsg"))))
+ "1avdsw1l61gwr29lzvlr4dh3qz6ypsc3xvfahrcprlqa34mzp9jk"))))
(build-system meson-build-system)
(arguments
;; GTK 4.x depends on Rust (indirectly) so pull it only on platforms
;; where it is supported.
- (list #:configure-flags (if (supported-package? gtk)
- #~(list "-Dlibnma_gtk4=true")
- #~(list "-Dlibnma_gtk4=false"))))
+ (list
+ #:configure-flags
+ (if (supported-package? gtk)
+ #~(list "-Dlibnma_gtk4=true")
+ #~(list "-Dlibnma_gtk4=false"))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; We follow upstream's recommendation at
+ ;; https://gitlab.gnome.org/GNOME/libnma/-/commit/9166164387b0367becbe3400af696f925fef0ab1
+ (add-after 'install 'delete-org.gnome.nm-applet.gschema
+ (lambda _
+ (delete-file
+ (string-append
+ #$output
+ "/share/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml")))))))
(native-inputs
(list docbook-xml-4.3
gettext-minimal