summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-07 20:42:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-07 20:42:03 +0200
commit20e3f3e1151b2f22ae7fb5aa8764148654f35090 (patch)
tree3f6af3a73f4548b8f6564a31984abeeefd60b0ef /gnu/packages/gnome.scm
parent965e2d6eb90826181471b834437ac68dcb9217cb (diff)
parent451ba2e5bb523c18a2ccc941df47b598c48ef57e (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 18 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1f91156da4..ad118090eb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11418,7 +11418,7 @@ and uncluttered interface for the management of password databases.")
(define-public sound-juicer
(package
(name "sound-juicer")
- (version "3.38.0")
+ (version "3.40.0")
(source
(origin
(method url-fetch)
@@ -11427,15 +11427,25 @@ and uncluttered interface for the management of password databases.")
name "-" version ".tar.xz"))
(sha256
(base32
- "08d5d81rz9sj3m5paw8fwbgxmhlbr7bcjdzpmzj832qvg8smydxf"))))
+ "1rhxmvx2mr22zd5p0azc0svi0mbnzcjnh3sasv3b9gli8ds85s1f"))))
(build-system meson-build-system)
(arguments
(list
#:glib-or-gtk? #t
- #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-gtk-update-icon-cache
- (lambda _
- (setenv "DESTDIR" "/"))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
+ (add-after 'install 'wrap-program
+ (lambda _
+ (let ((prog (string-append #$output "/bin/sound-juicer"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program prog
+ `("GST_PLUGIN_SYSTEM_PATH"
+ ":" prefix (,gst-plugin-path)))))))))
(native-inputs
(list desktop-file-utils
gettext-minimal
@@ -11445,7 +11455,8 @@ and uncluttered interface for the management of password databases.")
pkg-config
python))
(inputs
- (list brasero
+ (list bash-minimal
+ brasero
gsettings-desktop-schemas
gst-plugins-base
gst-plugins-good