summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-10-31 20:35:00 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-02 18:59:13 +0100
commit492e621a57e9c3fb340624c03fbf5bf1a8f7de6d (patch)
treefb20af8130fd88cd8a239545fee36c9c9a1cb835 /gnu/packages/gnome.scm
parent60632b0a147e011ffe8162a67a12f104a33f49d8 (diff)
gnu: Add libcall-ui.
* gnu/packages/gnome.scm (libcall-ui): New variable. * gnu/packages/patches/libcall-ui-make-it-installable.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Change-Id: I47c403d12c90f9371a8065d2d8d8e829225e5f0c Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0b461e4296..b2de06803a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13479,3 +13479,44 @@ historical battery usage and related statistics.")
(home-page "http://xffm.org/")
(license license:gpl3+)
(properties '((upstream-name . "xffm")))))
+
+(define-public libcall-ui
+ (package
+ (name "libcall-ui")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/World/Phosh/libcall-ui")
+ (commit "6798b38d4d66d069751151b3e9a202c6de8d7f3c")))
+ (file-name (git-file-name "libcall-ui" version))
+ (sha256
+ (base32
+ "0zfrxh77ag8garqj319amnxjcdyp3ig12dkxfkl6wbwn1mvyrwx8"))
+ (patches (search-patches "libcall-ui-make-it-installable.patch"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
+ (propagated-inputs ; All these in call-ui.pc.
+ (list glib
+ gtk+
+ (@ (gnu packages telephony) libcallaudio)
+ libhandy))
+ (native-inputs
+ (list `(,glib "bin") ; glib-mkenums
+ pkg-config
+ xorg-server-for-tests))
+ (synopsis "Common User Interfaces for call handling")
+ (description "This package provides common user interfaces to make and
+receive calls.")
+ (home-page "https://gitlab.gnome.org/World/Phosh/libcall-ui")
+ (license license:lgpl2.1+)))