summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-11-16 23:18:12 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-17 20:30:15 +0100
commit51f8803488395cc0c89c4a8350c727c4dfd9f3e4 (patch)
treec9242a61fc1bffe36b3ad1329ade1fb3d7a0d60d /gnu/packages/gnome.scm
parente1918fafec541e7f1c83ccd76d700ce8a4428f58 (diff)
gnu: gnome-calculator: Update style.
* gnu/packages/gnome.scm (gnome-calculator) [arguments]: Convert to list of G-Expressions. Change-Id: I217aec53e66808cc11a26f5df58fd25355d898b0 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8b3b3d83a9..35f7766b2d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10813,18 +10813,19 @@ handling the startup notification side.")
"0hqhnwaw7zam0r7b61ir68710hxmc5rxb0172mz9lc48kwr67rql"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- (lambda _
- (substitute* "meson.build"
- (("gtk_update_icon_cache: true")
- "gtk_update_icon_cache: false"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a writable HOME.
- (setenv "HOME" (getcwd)))))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a writable HOME.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
(list gettext-minimal
`(,glib "bin") ;for glib-compile-schemas, gio-2.0.