summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2023-05-16 01:12:59 -0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-21 22:18:46 +0200
commit7bcb72b3317f09030aac58a765e533f40c0f751d (patch)
treeee7b9a342474bdf256ce75f4938c599a202fb12e /gnu/packages/gnome.scm
parent8a21c038efa9c74a6d421503abbd5989b83c1c40 (diff)
gnu: geary: Use G-Expressions.
* gnu/packages/gnome.scm (geary)[arguments]: Convert to list of G-Expressions. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm69
1 files changed, 34 insertions, 35 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2ba299d308..bb3266b05a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12318,41 +12318,40 @@ non-privileged user.")
"04hvw86r8sczvjm1z3ls5y5y5h6nyfb648rjkfx05ib00mqq5v1x"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:configure-flags
- '("-Dprofile=release")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "test/test-client.vala"
- (("client.add_suite\\(new Application.CertificateManagerTest\\(\\).suite\\);")
- ""))
- (substitute* "test/test-engine.vala"
- (("engine.add_suite\\(new Geary.RFC822.MessageDataTest\\(\\).suite\\);")
- ""))))
- (add-after 'unpack 'generate-vapis
- (lambda* (#:key inputs #:allow-other-keys)
- ;; It’s not possible to generate the GMime vapi, because
- ;; there’s custom metadata that gmime didn’t
- ;; install. Thus, the vapi should be built and installed
- ;; with gmime.
- (define gmime
- (assoc-ref inputs "gmime"))
- (copy-file (string-append gmime "/share/vala/vapi/gmime-3.0.vapi")
- "bindings/vapi/gmime-3.0.vapi")))
- (add-after 'unpack 'disable-postinstall-script
- (lambda _
- (substitute* "build-aux/post_install.py"
- (("gtk-update-icon-cache")
- "true"))))
- (add-before 'check 'setup-home
- (lambda _
- ;; Tests require a writable HOME.
- (setenv "HOME" (getcwd))))
- (add-before 'check 'setup-xvfb
- (lambda _
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))))
+ (list #:glib-or-gtk? #t
+ #:configure-flags
+ #~(list "-Dprofile=release")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "test/test-client.vala"
+ (("client.add_suite\\(new Application.CertificateManagerTest\\(\\).suite\\);")
+ ""))
+ (substitute* "test/test-engine.vala"
+ (("engine.add_suite\\(new Geary.RFC822.MessageDataTest\\(\\).suite\\);")
+ ""))))
+ (add-after 'unpack 'generate-vapis
+ (lambda _
+ ;; It’s not possible to generate the GMime vapi, because
+ ;; there’s custom metadata that gmime didn’t
+ ;; install. Thus, the vapi should be built and installed
+ ;; with gmime.
+ (copy-file #$(file-append gmime "/share/vala/vapi/gmime-3.0.vapi")
+ "bindings/vapi/gmime-3.0.vapi")))
+ (add-after 'unpack 'disable-postinstall-script
+ (lambda _
+ (substitute* "build-aux/post_install.py"
+ (("gtk-update-icon-cache")
+ "true"))))
+ (add-before 'check 'setup-home
+ (lambda _
+ ;; Tests require a writable HOME.
+ (setenv "HOME" (getcwd))))
+ (add-before 'check 'setup-xvfb
+ (lambda _
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
(inputs
(list enchant
folks-with-libsoup2