summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-09-15 20:07:13 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-15 22:29:22 +0200
commit8c28401c6d0e8ea69edef80a82e2af31abab93e8 (patch)
tree238f4d4beec40c0d6a42c261b3b348967ed68670 /gnu/packages/gnome.scm
parent5c8721ad07d9b2af06a938dae29651f2be41dac1 (diff)
gnu: libshumate: Update to 1.0.5.
* gnu/packages/gnome.scm (libshumate): Update to 1.0.5. [#:phases]:<pre-check>: Removed, moving logic… <check>: … here. Also set other environment variables and run tests using ‘dbus-run-session’. [native-inputs]: Add dbus and at-spi2-core. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm36
1 files changed, 23 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3e461729ab..16516d289c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4944,7 +4944,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libshumate
(package
(name "libshumate")
- (version "1.0.0.beta") ;no stable release yet
+ (version "1.0.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4952,25 +4952,35 @@ libxml to ease remote use of the RESTful API.")
name "-" version ".tar.xz"))
(sha256
(base32
- "13xrc07fm0967gzbqab8k0l3dnknh00p0a6f2dm7k0aa56q41sda"))))
+ "0v4m07vxm3m4a2vqkp2wfsc3zsf92fpigc1k8yq49vkpj7gxikx8"))))
(build-system meson-build-system)
- (arguments (list #:configure-flags #~(list "-Dlibsoup3=true")
- #:phases #~(modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- ;; The 'coordinate' test requires a
- ;; writable HOME.
- (setenv "HOME" "/tmp")
+ (arguments
+ (list #:configure-flags #~(list "-Dlibsoup3=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-options #:allow-other-keys)
+ (when tests?
+ ;; Some tests expect to write to $HOME.
+ (setenv "HOME" "/tmp")
+ (setenv "XDG_RUNTIME_DIR" "/tmp/run")
+ (setenv "XDG_CACHE_HOME" "/tmp/cache")
+
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))))
+ (apply invoke "dbus-run-session" "--" "meson" "test"
+ "--print-errorlogs" test-options)))))))
(native-inputs
(list gi-docgen
`(,glib "bin")
gobject-introspection
pkg-config
- xorg-server-for-tests))
+ ;; For tests:
+ xorg-server-for-tests
+ dbus
+ at-spi2-core))
(propagated-inputs
;; All the libraries are listed as "Requires' in the .pc file.
(list cairo