summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 09:43:41 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:39 +0000
commit96b755b42a7a3677b964be2f820b87458558c421 (patch)
treee792dcdf1bac053ac213e3530da7fa4958542e53 /gnu/packages/gnome.scm
parent19ded2afe59595d342f9f1f885970fc10529f66b (diff)
gnu: gnome-online-miners: Fix build.
* gnu/packages/patches/gnome-online-miners-tracker-3.patch: New file. * gnu/local.mk (DIST_PATCH_DATA): Add it. * gnu/packages/gnome.scm (gnome-online-miners)[source]: Use it. [arguments]: Add a 'fix-configure and a 'autoreconf phase. [inputs]: Add autoconf, automake and libtool.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d75f478539..0aa9b80aee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -919,6 +919,7 @@ tomorrow, the rest of the week and for special occasions.")
("libdazzle" ,libdazzle)
("libgdata" ,libgdata)
("libgfbgraph" ,gfbgraph)
+ ("libhandy" ,libhandy)
("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("librest" ,rest)
@@ -1284,13 +1285,30 @@ in the GNOME desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1n2jz9i8a42zwxx5h8j2gdy6q1vyydh4vl00r0al7w8jzdh24p44"))))
+ "1n2jz9i8a42zwxx5h8j2gdy6q1vyydh4vl00r0al7w8jzdh24p44"))
+ (patches
+ (search-patches
+ "gnome-online-miners-tracker-3.patch"))))
(build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-configure
+ (lambda _
+ (substitute* "configure.ac"
+ (("AX_CHECK_ENABLE_DEBUG.*")
+ ""))))
+ (add-after 'fix-configure 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(inputs
`(("gnome-online-accounts" ,gnome-online-accounts)