summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-19 20:51:13 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-19 20:51:13 +0200
commit96c78878645f33b64b4b60fe8e1399c902b7facd (patch)
tree6fef0f4ec74583b33987eef8d349a652c7008ddc /gnu/packages/gnome.scm
parent72fe3c0a35f04a6616c17228953a20861ce9b690 (diff)
gnu: gnome-todo: Update to "Endeavour" 42.0.
* gnu/packages/gnome.scm (gnome-todo): Deprecate and rename to... (endeavour): ... this. [source]: Use git origin. * gnu/packages/patches/gnome-todo-libportal.patch: Deleted file. * gnu/local.mk (dist_patch_DATA): Update accordingly.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8a49040f4..9229abb41d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10252,19 +10252,18 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
desktop. It supports multiple calendars, month, week and year view.")
(license license:gpl3+)))
-(define-public gnome-todo
+(define-public endeavour
(package
- (name "gnome-todo")
- (version "41.0")
+ (name "endeavour")
+ (version "42.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major version) "/"
- name "-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/World/Endeavour")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1r94880d4khbjhhfnhaba3y3d4hv2bri82rzfzxn27s5iybpqras"))
- (patches (search-patches "gnome-todo-libportal.patch"))))
+ "0d6by7aq8db35zavzvckcxxxcdi6qnv0mkjndhb0syc8ih15dpak"))))
(build-system meson-build-system)
(arguments
(list
@@ -10309,6 +10308,9 @@ desktop. It supports multiple calendars, month, week and year view.")
to perfectly fit the GNOME desktop.")
(license license:gpl3+)))
+(define-public gnome-todo
+ (deprecated-package "gnome-todo" endeavour))
+
(define-public gnome-dictionary
(package
(name "gnome-dictionary")