summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMcKinley Olsen <mck.olsen@gmail.com>2016-05-31 14:28:44 -0600
committer宋文武 <iyzsong@gmail.com>2016-06-01 21:25:16 +0800
commitc44fb4df8a2114b482285d522033050c1c94dfba (patch)
tree71c4a77ea0e61d024a8205d7f733b20531951384 /gnu/packages/gnome.scm
parent1c6303fae05815d3127a6bc480b1a794ad5dc49f (diff)
gnu: Add vte-ng.
* gnu/packages/gnome.scm (vte-ng): New variable. Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0d9c946fd5..8384c76d66 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1787,6 +1787,39 @@ gnome-terminal, but can also be used to embed a console/terminal in games,
editors, IDEs, etc.")
(license license:lgpl2.1+)))
+(define-public vte-ng
+ (package
+ (inherit vte)
+ (name "vte-ng")
+ (version "0.44.1.b")
+ (native-inputs
+ `(("gtk-doc" ,gtk-doc)
+ ("gperf" ,gperf)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ,@(package-native-inputs vte)))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/thestinger/"
+ name "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mhz4i1qkdlrs49vgm7nsrb60lry9v6wsgwsmji7fln1nyrp1pag"))))
+ (arguments
+ `(#:configure-flags '("CXXFLAGS=-Wformat=0")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (setenv "NOCONFIGURE" "true")
+ (zero? (system* "sh" "autogen.sh")))))))
+ (synopsis "Enhanced VTE terminal widget")
+ (description
+ "VTE is a library (libvte) implementing a terminal emulator widget for
+GTK+, this fork provides additional functions exposed for keyboard text
+selection and URL hints.")))
+
;; provides vte 2.90, required for some terminal emulators
;; tilda bug: https://github.com/lanoxx/tilda/issues/94
;; pantheon-terminal bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=788021