summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-12-05 17:33:01 +0100
committerKei Kebreau <kkebreau@posteo.net>2019-06-20 23:24:38 -0400
commite762d943e5eebcc57b3f86ed117cd5ba203e54f2 (patch)
treeb91eab8855a37679056af95901edd7d0dc06b46e /gnu/packages/gnome.scm
parentd0b19e445cd542b8336e47801c6aacd9361ed5a7 (diff)
gnu: gvfs: Update to 1.38.1.
* gnu/packages/gnome.scm (gvfs): Update to 1.38.1. [build-system]: Use meson-build-system. [arguments]: Remove custom phases; add configure flags to build without systemd; set glib-or-gtk? flag; enable tests; add sub-directory to RUNPATH. [native-inputs]: Remove autoconf, automake, and libtool. [inputs]: Add elogind, gnome-online-accounts, libgdata, libnfs, and openssh.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 16 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 221c79e6a9..cdf361e5fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -81,6 +81,7 @@
#:use-module (gnu packages enchant)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages game-development)
@@ -4161,7 +4162,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
(define-public gvfs
(package
(name "gvfs")
- (version "1.36.2")
+ (version "1.38.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4169,21 +4170,20 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1xq105596sk9yram5a143b369wpaiiwc9gz86n0j1kfr7nipkqn4"))))
- (build-system gnu-build-system)
+ "18311pn5kp9b4kf5prvhcjs0cwf7fm3mqh6s6p42avcr5j26l4zd"))))
+ (build-system meson-build-system)
(arguments
- '(#:tests? #f ; XXX: requiring `pidof'
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-broken-autogen-script
- (lambda _ (delete-file "autogen.sh") #t)))))
+ '(#:glib-or-gtk? #t
+ #:configure-flags
+ (list "-Dsystemduserunitdir=no"
+ "-Dtmpfilesdir=no"
+ ;; Otherwise, the RUNPATH will lack the final path component.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/gvfs"))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
- ("autoconf" ,autoconf)
- ("automake" ,automake)
("gettext" ,gettext-minimal)
("gtk-doc" ,gtk-doc)
- ("libtool" ,libtool)
("pkg-config" ,pkg-config)
("xsltproc" ,libxslt)))
(inputs
@@ -4191,23 +4191,28 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
("docbook-xml" ,docbook-xml-4.2)
("docbook-xsl" ,docbook-xsl)
("dbus" ,dbus)
+ ("elogind" ,elogind)
("fuse" ,fuse)
("gcr" ,gcr)
("glib" ,glib)
+ ("gnome-online-accounts" ,gnome-online-accounts)
("libarchive" ,libarchive)
("libbluray" ,libbluray)
("libcap" ,libcap)
("libcdio-paranoia" ,libcdio-paranoia)
("libgcrypt" ,libgcrypt)
+ ("libgdata" ,libgdata)
("libgphoto2" ,libgphoto2)
("libgudev" ,libgudev)
("libimobiledevice" ,libimobiledevice)
("libmtp" ,libmtp)
+ ("libnfs" ,libnfs)
("libsecret" ,libsecret)
("libsmbclient" ,samba)
("libsoup" ,libsoup)
("libxml2" ,libxml2)
("nettle" ,nettle) ; XXX: required by libarchive.pc
+ ("openssh" ,openssh)
("polkit" ,polkit)
("udisks" ,udisks)))
(home-page "https://wiki.gnome.org/gvfs/")