summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorDominik Delgado Steuter <d@delgado.nrw>2023-04-27 00:22:41 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-25 12:51:16 +0200
commite7ab908e0a9e01863f566caeff0b527a86322b15 (patch)
treee3b62ea94d7bedd279290ba3d6d0633ecca64c76 /gnu/packages/gnome.scm
parent1af79a0615094ba0d86f4c5580481ed8cd181cd9 (diff)
gnu: Add dialect.
* gnu/packages/gnome.scm (dialect): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2b071de9d3..7df18f055f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -75,6 +75,7 @@
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10409,6 +10410,45 @@ to perfectly fit the GNOME desktop.")
(define-public gnome-todo
(deprecated-package "gnome-todo" endeavour))
+(define-public dialect
+ (package
+ (name "dialect")
+ (version "2.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dialect-app/dialect")
+ (commit version)
+ (recursive? #t))) ;po module
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wac9r33zslyhvadyj7iaapskk7f9pfvia7zlqfksfhkaji6gmna"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
+ (native-inputs (list blueprint-compiler
+ desktop-file-utils
+ `(,glib "bin")
+ gnu-gettext
+ gobject-introspection
+ `(,gtk "bin")
+ pkg-config))
+ (propagated-inputs (list gstreamer
+ libadwaita
+ libsoup
+ python
+ python-gtts
+ python-pygobject
+ python-requests))
+ (home-page "https://apps.gnome.org/app/app.drey.Dialect")
+ (synopsis "Translation application for GNOME")
+ (description
+ "Dialect is a simple translation application that uses Google Translate
+(default), LibreTranslate or Lingva Translate. It includes features
+like automatic language detection, text-to-speech and clipboard buttons.")
+ (license license:gpl3+)))
+
(define-public gnome-dictionary
(package
(name "gnome-dictionary")