summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-10 01:55:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:51 -0400
commite8de035b95193910357272e27481f8993227bc3e (patch)
treeacb85c06a494f81e03fab122396cb657655beb28 /gnu/packages/gnome.scm
parenteb93a78df8841628b07e2bb1c44673f68da1f389 (diff)
gnu: libgovirt: Update to 0.3.9.
* gnu/packages/gnome.scm (libgovirt): Update to 0.3.9. [build-system]: Use meson-build-system. [glib-or-gtk?]: New argument. [inputs]: Replace rest with rest-next. Move glib-networking to... [native-inputs]: ... here. Remove gtk+:bin.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm56
1 files changed, 31 insertions, 25 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 42141334af..69ede24940 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9692,31 +9692,37 @@ associations for GNOME.")
(define-public libgovirt
(package
- (name "libgovirt")
- (version "0.3.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1y0x1wyakj3ya33hgj0w1jkbcn50q21gmn2zyalxysqp55i1ij8x"))))
- (build-system glib-or-gtk-build-system)
- (native-inputs
- (list gettext-minimal
- `(,glib "bin")
- gobject-introspection
- gsettings-desktop-schemas
- `(,gtk+ "bin")
- pkg-config))
- (inputs
- (list glib-networking ; GIO plugin--for the tests
- rest))
- (synopsis "GoVirt Library")
- (description "GoVirt is a GObject wrapper for the oVirt REST API.")
- (home-page "https://gitlab.gnome.org/GNOME/libgovirt")
- (license license:gpl2+)))
+ (name "libgovirt")
+ (version "0.3.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0z118di7cg654f5zb8xn5w60ghgqngsc1p7izr1pw01dkxbw6bxi"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-home
+ (lambda _
+ ;; The tests require a writable HOME.
+ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ glib-networking ; GIO plugin--for the tests
+ gobject-introspection
+ gsettings-desktop-schemas
+ pkg-config))
+ (inputs
+ (list rest-next))
+ (synopsis "GoVirt Library")
+ (description "GoVirt is a GObject wrapper for the oVirt REST API.")
+ (home-page "https://gitlab.gnome.org/GNOME/libgovirt")
+ (license license:gpl2+)))
(define-public gnome-weather
(package