summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-05-23 14:07:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-24 12:00:17 +0200
commite99a3d6fd254e2ba5f1864f7679e35cb6a9054f3 (patch)
treeb7b898ea3095860e54d5f89e6450d810fd7e1b86 /gnu/packages/gnome.scm
parent8ff490119659453d7902c01a8caac36720158546 (diff)
gnu: Add gnome-keyring.
* gnu/packages/gnome.scm (gnome-keyring): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index db59d9ae01..6e5e7bbca7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -257,6 +257,73 @@ GNOME Desktop.")
;; Though a couple of files are LGPLv2.1+.
(license license:lgpl2.0+)))
+(define-public gnome-keyring
+ (package
+ (name "gnome-keyring")
+ (version "3.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1xg1xha3x3hzlmvdq2zm90hc61pj7pnf9yxxvgq4ynl5af6bp8qm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;48 of 603 tests fail because /var/lib/dbus/machine-id does
+ ;not exist
+ #:configure-flags
+ (list
+ (string-append "--with-pkcs11-config="
+ (assoc-ref %outputs "out") "/share/p11-kit/modules/")
+ (string-append "--with-pkcs11-modules="
+ (assoc-ref %outputs "out") "/share/p11-kit/modules/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "build/tap-driver"
+ (("/usr/bin/env python") (which "python")))))
+ (add-before
+ 'configure 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "docs/Makefile.am"
+ (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))
+ (setenv "XML_CATALOG_FILES"
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/catalog.xml")))))))
+ (inputs
+ `(("libgcrypt" ,libgcrypt)
+ ("dbus" ,dbus)
+ ("gcr" ,gcr)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
+ ("python" ,python-2) ;for tests
+ ("intltool" ,intltool)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libxslt" ,libxslt) ;for documentation
+ ("docbook-xml" ,docbook-xml-4.2)
+ ("docbook-xsl" ,docbook-xsl)))
+ (home-page "http://www.gnome.org")
+ (synopsis "Daemon to store passwords and encryption keys")
+ (description
+ "gnome-keyring is a program that keeps passwords and other secrets for
+users. It is run as a daemon in the session, similar to ssh-agent, and other
+applications locate it via an environment variable or D-Bus.
+
+The program can manage several keyrings, each with its own master password,
+and there is also a session keyring which is never stored to disk, but
+forgotten when the session ends.")
+ (license license:lgpl2.1+)))
+
(define-public evince
(package
(name "evince")