summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-29 22:20:52 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-06 21:47:56 +0200
commitf1c70ac025e48629fdd8f005030e0678bf7ba040 (patch)
treea3fe10add81321daa45a7df121bafdf5aefe1cc6 /gnu/packages/gnome.scm
parent69ed4f137dce7d2cdbb99d55fde90eaa4b0b1b21 (diff)
gnu: mutter: Update to 44.3.
* gnu/packages/gnome.scm (mutter): Update to 44.3. [arguments]: Adjust linker rpath accordingly. [inputs]: Add colord.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f437b712b4..90946716b3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7761,7 +7761,7 @@ to display dialog boxes from the commandline and shell scripts.")
(define-public mutter
(package
(name "mutter")
- (version "42.4")
+ (version "44.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -7769,7 +7769,7 @@ to display dialog boxes from the commandline and shell scripts.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0h1ak3201mdc2qbf67fhcn801ddp33hm0f0c52zis1l7s6ipyb62"))
+ "0l85qyn6x5hyaaclzcbqd44xpd582gdindqfam8f9lsh46zvwp0q"))
;; TODO: Remove on update as this was merged upstream. See
;; <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>.
(patches (search-patches "mutter-fix-inverted-test.patch"))))
@@ -7792,7 +7792,7 @@ to display dialog boxes from the commandline and shell scripts.")
;; Otherwise, the RUNPATH will lack the final path component.
(string-append "-Dc_link_args=-Wl,-rpath="
#$output "/lib,-rpath="
- #$output "/lib/mutter-10")
+ #$output "/lib/mutter-12")
;; Disable systemd support.
"-Dsystemd=false"
;; Don't install tests.
@@ -7939,7 +7939,8 @@ to display dialog boxes from the commandline and shell scripts.")
pango
xinput))
(inputs
- (list egl-wayland ;for wayland-eglstream-protocols
+ (list colord
+ egl-wayland ;for wayland-eglstream-protocols
elogind
gnome-desktop
gnome-settings-daemon