summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-03-08 23:04:35 +0100
committerLeo Famulari <leo@famulari.name>2016-03-09 15:55:33 -0500
commitfb9ca51130a6939a665dccbc331de3e30cf8dd88 (patch)
tree1908f9409ea562c873005f9b8478beae46aef692 /gnu/packages/gnome.scm
parentf97334220ce80952cffa03e5985502c9c0f63599 (diff)
gnu: simple-scan: Update to 3.19.91.
* gnu/packages/gnome.scm (simple-scan): Update to 3.19.91. [arguments]: Add 'clean' phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c945c0e658..0f37f90cbd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3382,7 +3382,7 @@ USB transfers with your high-level application or system daemon.")
(define-public simple-scan
(package
(name "simple-scan")
- (version "3.17.4")
+ (version "3.19.91")
(source (origin
(method url-fetch)
(uri (string-append "https://launchpad.net/simple-scan/"
@@ -3391,7 +3391,7 @@ USB transfers with your high-level application or system daemon.")
version ".tar.xz"))
(sha256
(base32
- "1pslbv45g01g039zj2b01k08f763kkhzqw8wwz7yh27m7bjllnx6"))))
+ "1c5glf5vxgld41w4jxfqcv17q76qnh43fawpv33hncgh8d283xkf"))))
(build-system glib-or-gtk-build-system)
(inputs
`(("gtk" ,gtk+)
@@ -3409,6 +3409,21 @@ USB transfers with your high-level application or system daemon.")
("pkg-config" ,pkg-config)
("vala" ,vala)
("xmllint" ,libxml2)))
+ (arguments
+ '(#:configure-flags '("--disable-packagekit")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'clean
+ (lambda _
+ ;; Remove a left-over reference to PackageKit.
+
+ ;; https://bugs.launchpad.net/simple-scan/+bug/1462769
+
+ ;; There are some generated C files erroneously
+ ;; included in the source distribution, and this
+ ;; one breaks the build by referring to a
+ ;; non-existent header (packagekit.h)
+ (delete-file "src/ui.c"))))))
(home-page "https://launchpad.net/simple-scan")
(synopsis "Document and image scanner")
(description "Simple Scan is an easy-to-use application, designed to let