summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-03-01 18:35:41 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-01 20:19:11 +0100
commitfbdb2cf57ae66e929e24a7f0b53dbfa09417b6ea (patch)
tree5841111cbf2864eb16108a914b5f08de6fb0d5a6 /gnu/packages/gnome.scm
parentf469a45362afd3b41bc1b70277fb66a14df99a2d (diff)
gnu: gnome-terminal: Update to 3.48.3.
* gnu/packages/gnome.scm (gnome-terminal): Update to 3.48.3. [source]: Use the git-fetch method. Change-Id: I44dee8cec5afbd4f5e7e486b54f893ce6a3e1d06 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f428bfeb78..9cd7c6ba5d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5475,16 +5475,19 @@ more fun.")
(define-public gnome-terminal
(package
(name "gnome-terminal")
- (version "3.44.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0yykb64yi1h0g65q890jf5awjr2sdvfda4xbxnmajcgj3zp20vzv"))))
+ (version "3.48.3")
+ ;; download.gnome.org does not have any version for gnome-terminal more
+ ;; recent than 3.44.1, but the repository has several tags newer than
+ ;; that.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/gnome-terminal")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cqh35j57a5ni4xlfjzl46kim6nbhqvxx3jql3gjk414z359i0j6"))))
(build-system meson-build-system)
(arguments
(list