summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-21 14:59:29 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-09-21 14:59:29 +0000
commitfd672f30d0ac88c62b3216fc3c7ec98eeec3ad39 (patch)
treeaaf55a98593c4279b48dd2661fcf8a6170c0c0b5 /gnu/packages/gnome.scm
parent94006cc29cbfb8ea53f68cb335358e1b6d6692c1 (diff)
gnu: Add gnome-power-manager.
* gnu/packages/gnome.scm (gnome-power-manager): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index deeeab5b32..fe760f8763 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2020, 2021 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2021 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
+;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12329,3 +12330,32 @@ world.")
(description "OCRFeeder is a complete Optical Character Recognition and
Document Analysis and Recognition program.")
(license license:gpl3+)))
+
+(define-public gnome-power-manager
+ (package
+ (name "gnome-power-manager")
+ (version "3.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0drfn3wcc8l4n07qwv6p0rw2dwcd00hwzda282q62l6sasks2b2g"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("upower" ,upower)
+ ("gtk+" ,gtk+)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("adwaita-icon-theme" ,adwaita-icon-theme)))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin")
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-power-manager")
+ (synopsis "Power management daemon for the GNOME desktop")
+ (description "@code{gnome-power-manager} is a tool for viewing present and
+historical battery usage and related statistics.")
+ (license license:gpl2)))