summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-20 02:57:50 +0200
committerMarius Bakke <marius@gnu.org>2022-07-23 19:43:10 +0200
commitfff973b03c4889b30744c4b2a02ff8c6915bb786 (patch)
tree70815e3790232f7dabc553b0c78e52b4c1e408ad /gnu/packages/gnupg.scm
parent259de44042d1fdbf1a6262e7e96800d75416e95c (diff)
gnu: GnuPG: Use G-expression.
* gnu/packages/gnupg.scm (gnupg)[arguments]: Convert to gexp. Remove input label usage, and simplify regular expression.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm62
1 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 74ff871c58..ba9242a09b 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -316,37 +316,39 @@ compatible to GNU Pth.")
readline
sqlite
zlib))
- (arguments
- `(#:configure-flags '(;; Otherwise, the test suite looks for the `gpg`
- ;; executable in its installation directory in
- ;; /gnu/store before it has been installed.
- "--enable-gnupg-builddir-envvar"
- "--enable-all-tests")
+ (arguments
+ (list
+ #:configure-flags #~'(;; Otherwise, the test suite looks for the `gpg`
+ ;; executable in its installation directory in
+ ;; /gnu/store before it has been installed.
+ "--enable-gnupg-builddir-envvar"
+ "--enable-all-tests")
#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "scd/scdaemon.c"
- (("\"(libpcsclite\\.so[^\"]*)\"" _ name)
- (string-append "\"" (assoc-ref inputs "pcsc-lite")
- "/lib/" name "\"")))))
- (add-after 'build 'patch-scheme-tests
- (lambda _
- (substitute* (find-files "tests" ".\\.scm$")
- (("/usr/bin/env gpgscm")
- (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
- (add-before 'build 'patch-test-paths
- (lambda _
- (substitute* '("tests/inittests"
- "tests/pkits/inittests"
- "tests/Makefile"
- "tests/pkits/common.sh"
- "tests/pkits/Makefile")
- (("/bin/pwd") (which "pwd")))
- (substitute* "common/t-exectool.c"
- (("/bin/cat") (which "cat"))
- (("/bin/true") (which "true"))
- (("/bin/false") (which "false"))))))))
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libpcsclite.so (search-input-file inputs
+ "lib/libpcsclite.so")))
+ (substitute* "scd/scdaemon.c"
+ (("libpcsclite\\.so")
+ libpcsclite.so)))))
+ (add-after 'build 'patch-scheme-tests
+ (lambda _
+ (substitute* (find-files "tests" ".\\.scm$")
+ (("/usr/bin/env gpgscm")
+ (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
+ (add-before 'build 'patch-test-paths
+ (lambda _
+ (substitute* '("tests/inittests"
+ "tests/pkits/inittests"
+ "tests/Makefile"
+ "tests/pkits/common.sh"
+ "tests/pkits/Makefile")
+ (("/bin/pwd") (which "pwd")))
+ (substitute* "common/t-exectool.c"
+ (("/bin/cat") (which "cat"))
+ (("/bin/true") (which "true"))
+ (("/bin/false") (which "false"))))))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")
(description