summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2020-06-15 04:12:10 -0400
committerMark H Weaver <mhw@netris.org>2020-06-18 03:13:08 -0400
commit416439263cb295260ba38ab1cce5b4468ae5691e (patch)
tree42e12ebeaceb39ecdec41c417d7716e5f4f582bf /gnu/packages/gnuzilla.scm
parent620796e66bb828ca22b5d4932275bc36a7b4706a (diff)
gnu: icecat: Remove the bundled Onion Browser Button [security].
Fixes <https://bugs.gnu.org/35728>. The Onion Browser Button (tortm-browser-button@jeremybenthum) version 0.1.8, available from addons.mozilla.org and bundled with IceCat, malfunctions with both IceCat 68.9 and Firefox ESR 68.9. It tells the user that it's connected to Tor, but fails to route traffic through it. The same happens on Debian 9 with its "firefox-esr" package. Remove this extension from IceCat, pending further investigation. * gnu/packages/gnuzilla.scm (icecat-source): Remove the "data/extensions/ tortm-browser-button@jeremybenthum" directory before running makeicecat.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 0a8edcb1e4..3bffe12577 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -648,6 +648,12 @@ from forcing GEXP-PROMISE."
"-p1" "--input" #+makeicecat-patch)
(invoke "patch" "--force" "--no-backup-if-mismatch"
"-p1" "--input" #+gnuzilla-fixes-patch)
+
+ ;; Remove the bundled tortm-browser-button extension,
+ ;; which doesn't seem to be working properly.
+ (delete-file-recursively
+ "data/extensions/tortm-browser-button@jeremybenthum")
+
(patch-shebang "makeicecat")
(substitute* "makeicecat"
(("^FFMAJOR=(.*)" all ffmajor)