summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2021-11-21 22:43:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-22 11:21:30 +0100
commit586a1ef9710532cd9e632e21edcb7226f203f1c5 (patch)
tree6e35b7bfe8a975bb8b7f4c457e5ffd1313c190a2 /gnu/packages/gnuzilla.scm
parent9d370029c21487c54b7bda4aa53e49251107a71f (diff)
gnu: Add lz4json.
* gnu/packages/gnuzilla.scm (lz4json): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 9edfcaa2ab..df344a1749 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Baptiste Strazzul <bstrazzull@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1992,3 +1993,41 @@ Thunderbird. It supports email, news feeds, chat, calendar and contacts.")
(description "Firefox Decrypt is a tool to extract passwords from
Mozilla (Firefox, Waterfox, Thunderbird, SeaMonkey) profiles.")
(license license:gpl3+)))
+
+(define-public lz4json
+ (package
+ (name "lz4json")
+ (version "2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/andikleen/lz4json")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xxn8yzr6j8j6prmbj6mxspdczigarfiv3vlm9k70yxmky65ijh3"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("lz4" ,lz4)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'install ; no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man/man1")))
+ (install-file "lz4jsoncat" bin)
+ (install-file "lz4jsoncat.1" man)))))
+ #:make-flags `(,(string-append "CC=" ,(cc-for-target)))))
+ (home-page "https://github.com/andikleen/lz4json")
+ (synopsis "C decompress tool for mozilla lz4json format")
+ (description
+ "@code{lz4json} is a little utility to unpack lz4json files as generated
+by Firefox's bookmark backups and session restore. This is a different format
+from what the normal lz4 utility expects. The data is dumped to stdout.")
+ (license license:bsd-2)))