summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2021-07-19 21:19:32 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2021-07-19 21:19:32 +0200
commitd84c24935bedb9b559f9c31fc07be47d9cc7adf5 (patch)
treeb8ad7e03e5b3a19c7368de2e98451b8de0e9ef1d /gnu/packages/gnuzilla.scm
parent52058a1144522ca6b552e565b50dce503671d37a (diff)
gnu: icedove: Update to 78.12.0 [security fixes].
Fixes CVE-2021-29969 and CVE-2021-29976. * gnu/packages/gnuzilla.scm (icedove): Update to 78.12.0.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 233e3104d0..4231e2a2d1 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1307,11 +1307,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20210601000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20210713000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "78.11.0")
+ (version "78.12.0")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1596,7 +1596,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "1717d8d5fbd359aab7a4a0a15f4d15c72a7e6afc"))
+ ,(let ((changeset "6796ff47626a009d169a1e9fd1f307a6c14b7ed5"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1605,7 +1605,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "10l042dd7b8rvla0cbiks5kjrz2b28yy7hr8sr169wlx202hxa01")))))
+ "1nnz90h5w9skpdwm8ilndcwfx9d7k9cn6gzh32y4jil95da13813")))))
("autoconf" ,autoconf-2.13)
("cargo" ,rust-1.41 "cargo")
("clang" ,clang)