summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-30 11:44:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-30 13:58:37 +0300
commitfce707186af8be1dccd46fdf609649e5dc2b9d23 (patch)
tree40ada88deeff0edefdfd893066f8401b721e0223 /gnu/packages/gnuzilla.scm
parent5b2ee0f3d2575e7c3983c241bcd96e696e1f25f3 (diff)
gnu: mozjs: Fix build on riscv64-linux.
* gnu/packages/gnuzilla.scm (mozjs)[arguments]: When building for riscv64-linux adjust the 'adjust-tests phase to skip 2 more tests skipped by upstream. Change-Id: Ia5fbe6782e3d1d8e1904cdf49a35e0666837b277
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 814b610bba..510cf1baab 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -176,6 +176,14 @@
((".*killed process should not have exitStatus.*")
""))
+ ;; This was fixed sometime between 102.15.1 and 115.11.0.
+ ;; These tests are supposed to be skipped on all 64-bit systems.
+ #$@(if (target-riscv64?)
+ #~((substitute* '("non262/Array/regress-157652.js"
+ "non262/regress/regress-422348.js")
+ (("mips64") "mips64|riscv64")))
+ #~())
+
;; The test suite expects a lightly patched ICU. Disable tests
;; that do not work with the system version. See
;; "intl/icu-patches" for clues.