summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 08:10:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:40 +0100
commit7e300af164d6abd8c6c203eda9d3d705e94390bc (patch)
tree5f219876a22192b6bf21ed12204a23bad89ad151 /gnu/packages/golang-build.scm
parent2ead21571210c1377750ac93b08cad4439b25427 (diff)
gnu: go-golang-org-x-sync: Fix indentation.
* gnu/packages/golang-build.scm (go-golang-org-x-sync): Re indent. Change-Id: I0399635dc8ddd2917b2f5920da883fa0459e7e30
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 45a57124be..9c56c38fd9 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -265,38 +265,38 @@ loading algorithms.")
(base32 "17zhim2m0r8nyy18g2lsawxm4rawix2qbjyn80x9vc6jc8fv05m9")))))))
(define-public go-golang-org-x-sync
- (package
- (name "go-golang-org-x-sync")
- (version "0.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/sync")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "03yq3pnjwqxqy1cvbkaa39ca2b9cli1k5wnz76l3a65n9fafai6q"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "golang.org/x/sync"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
- (home-page "https://go.googlesource.com/sync/")
- (synopsis "Additional Go concurrency primitives")
- (description "This package provides Go concurrency primitives in
+ (package
+ (name "go-golang-org-x-sync")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/sync")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03yq3pnjwqxqy1cvbkaa39ca2b9cli1k5wnz76l3a65n9fafai6q"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "golang.org/x/sync"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (home-page "https://go.googlesource.com/sync/")
+ (synopsis "Additional Go concurrency primitives")
+ (description "This package provides Go concurrency primitives in
addition to the ones provided by the language and “sync” and “sync/atomic”
packages.")
- (license license:bsd-3)))
+ (license license:bsd-3)))
(define-public go-golang-org-x-sys
(let ((commit "ca59edaa5a761e1d0ea91d6c07b063f85ef24f78")