summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 07:36:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:40 +0100
commit9708590d209aa2fea3a0f96a79bc3abb4c6d2395 (patch)
tree8889c1908cd66a8b7275a003350bf287129c950c /gnu/packages/golang-build.scm
parent9cfcc16c2f42cf62656e1da23bc43cee03787b43 (diff)
gnu: Remove go-golang.org-x-sync-errgroup.
* gnu/packages/golang-build.scm (go-golang.org-x-sync-errgroup): Delete variable. * gnu/packages/check.scm (actionlint): Adjust inputs. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (gotestsum): Likewise. [native-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/golang.scm (go-github-com-prometheus-procfs): Likewise. [propagated-inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/terminals.scm (go-github-com-junegunn-fzf): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. * gnu/packages/version-control.scm (ghq): Likewise. [inputs]: Remove go-golang.org-x-sync-errgroup; add go-golang-org-x-sync. Change-Id: If64c30da47ed9cd043798f427f2927b76394f3c4
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index bccacf59f4..d69746a9be 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -293,36 +293,9 @@ addition to the ones provided by the language and “sync” and “sync/atomic
packages.")
(license license:bsd-3))))
-(define-public go-golang.org-x-sync-errgroup
- (let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
- (revision "0"))
- (package
- (name "go-golang.org-x-sync-errgroup")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/sync")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1nqkyz2y1qvqcma52ijh02s8aiqmkfb95j08f6zcjhbga3ds6hds"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/sync/errgroup"
- #:unpack-path "golang.org/x/sync"))
- (home-page "https://godoc.org/golang.org/x/sync/errgroup")
- (synopsis "Synchronization, error propagation, and Context cancellation
-for groups of goroutines working on subtasks of a common task")
- (description "This package provides synchronization, error
-propagation, and Context cancellation for groups of goroutines working on
-subtasks of a common task.")
- (license license:bsd-3))))
-
(define-public go-golang.org-x-sync-semaphore
(package
- (inherit go-golang.org-x-sync-errgroup)
+ (inherit go-golang-org-x-sync)
(name "go-golang.org-x-sync-semaphore")
(arguments
'(#:import-path "golang.org/x/sync/semaphore"