summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-22 18:31:07 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:36:56 +0100
commitdbf3b5daf536c2dd73f6ca2d147a6daa6f259f5b (patch)
tree166aeddf32d58f7676558fae4fe4d561019d8fe5 /gnu/packages/golang-build.scm
parent11313556c59f01455533ec5f38b5a5317fe5863c (diff)
gnu: Remove go-golang-org-x-net-html.
golang.org/x/net is distributed as a single module according to provided go.mod file. This changes remove the last reference to golang.org/x/net/html. * gnu/packages/golang-build.scm (go-golang-org-x-net) [propagated-inputs]: Add go-golang-org-x-sys, go-golang-org-x-term and go-golang-org-x-text. (go-golang-org-x-net-html): Remove variable. * gnu/packages/version-control.scm (ghq) [inputs]: Remove go-golang-org-x-net-html. Add go-golang-org-x-net. * gnu/packages/textutils.scm (vale) [inputs]: Remove go-golang-org-x-net-html. Add go-golang-org-x-net. Change-Id: Ic275f2f7ccd145edfd376d65bd24599a550e849a
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index e13ce3afa8..bccacf59f4 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -238,6 +238,8 @@ loading algorithms.")
#~(modify-phases %standard-phases
;; Source-only package
(delete 'build))))
+ (propagated-inputs
+ (list go-golang-org-x-sys go-golang-org-x-term go-golang-org-x-text))
(home-page "https://go.googlesource.com/net")
(synopsis "Go supplemental networking libraries")
(description "This package provides supplemental Go networking libraries.")
@@ -262,19 +264,6 @@ loading algorithms.")
(sha256
(base32 "17zhim2m0r8nyy18g2lsawxm4rawix2qbjyn80x9vc6jc8fv05m9")))))))
-(define-public go-golang-org-x-net-html
- (package
- (inherit go-golang-org-x-net)
- (name "go-golang-org-x-net-html")
- (arguments
- '(#:import-path "golang.org/x/net/html"
- #:unpack-path "golang.org/x/net"))
- (propagated-inputs (list go-golang-org-x-text))
- (home-page "https://godoc.org/golang.org/x/net/html")
- (synopsis "HTML5-compliant tokenizer and parser")
- (description
- "This package provides an HTML5-compliant tokenizer and parser.")))
-
(define-public go-golang-org-x-sync
(let ((commit "8fcdb60fdcc0539c5e357b2308249e4e752147f1")
(revision "1"))