summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:02 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:29 -0400
commit6272d5f7be69fc063a817fb7ac29b4a0a368d9e6 (patch)
tree9194f40a66700c9324418d526ab05bf086dee710 /gnu/packages/golang-check.scm
parent981f0fee040fb9bfa4475f5a16fafd30f522196f (diff)
gnu: go-github-com-tdewolff-test: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-github-com-tdewolff-test): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 4b7ca74cc2..fe442bdb8b 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -157,6 +158,30 @@ Features include:
@end itemize")
(license license:expat)))
+(define-public go-github-com-tdewolff-test
+ (package
+ (name "go-github-com-tdewolff-test")
+ (version "1.0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdewolff/test")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10myz3zdkqmx37cvj507h7l2ncb0rq9shqvz9ggq1swijbsvazff"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/tdewolff/test"))
+ (home-page "https://github.com/tdewolff/test")
+ (synopsis "Go test helper functions")
+ (description
+ "This package implements a few functions that are useful for io testing,
+such as readers and writers that fail after N consecutive reads/writes.")
+ (license license:expat)))
+
(define-public go-gopkg-in-check-v1
(package
(name "go-gopkg-in-check-v1")