summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-compression.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-03-03 21:54:37 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:29 +0000
commit1583fe7e24b6e1a48f7525b338e96cecd5813a3a (patch)
treef42cc2c43666800b23a923be841d80aa5b43ba04 /gnu/packages/golang-compression.scm
parentfbc7a0efa7136d14265533932a19eb501214e7f9 (diff)
gnu: Add go-github-com-hhrutter-lzw.
* gnu/packages/golang-compression.scm (go-github-com-hhrutter-lzw): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-compression.scm')
-rw-r--r--gnu/packages/golang-compression.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index 568fdd12b9..031ff54f8a 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,6 +85,30 @@ the @code{c2go} tool at
compression format.")
(license license:bsd-3)))
+(define-public go-github-com-hhrutter-lzw
+ (package
+ (name "go-github-com-hhrutter-lzw")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hhrutter/lzw")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n13qhf8ih08jzm10wprdvjy56ylmy6fhakyqrddm6nszf397wch"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hhrutter/lzw"))
+ (home-page "https://github.com/hhrutter/lzw")
+ (synopsis "Extended version of @code{compress/lzw}")
+ (description
+ "This package provides an enhanced version of the @code{compress/lzw}
+library included in the stdlib, and supports GIF, TIFF and PDF.")
+ (license license:bsd-3)))
+
(define-public go-github-com-klauspost-compress
(package
(name "go-github-com-klauspost-compress")