summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:19:44 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:02 +0000
commit547eec541d3c1258a1d0a63b76e2f554715b6acd (patch)
tree7880df504530a0ae204feadcba7a529ecad193be /gnu/packages/golang-crypto.scm
parent0493c9cb199497bb750ab319710646b8546c539a (diff)
gnu: go-github-com-multiformats-go-multihash: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-multiformats-go-multihash): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/ipfs.scm: Add (gnu packages golang-crypto) to used modules. * gnu/packages/golang.scm: ... as above. Change-Id: I153be971141cf60390d03bf589c5121d9554cf9a
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 38ccc5ffe9..96e12a1194 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,36 @@
;;;
;;; Code:
+(define-public go-github-com-multiformats-go-multihash
+ (let ((commit "97cdb562a04c6ef66d8ed40cd62f8fbcddd396d6")
+ (revision "0"))
+ (package
+ (name "go-github-com-multiformats-go-multihash")
+ (version (git-version "1.0.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multihash")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02wd9akrwy4y5m0nig9m24p14bjjgb4n1djydrq8cm4yhbvjrrk0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/multiformats/go-multihash"))
+ (native-inputs
+ (list go-github-com-mr-tron-base58
+ go-github-com-gxed-hashland-keccakpg
+ go-github-com-minio-blake2b-simd
+ go-github-com-minio-sha256-simd
+ go-github-com-spaolacci-murmur3
+ go-golang-org-x-crypto))
+ (home-page "https://github.com/multiformats/go-multihash")
+ (synopsis "Multihash implementation in Go")
+ (description "Multihash implementation in Go.")
+ (license license:expat))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar