summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-17 22:27:14 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-07 00:55:56 +0100
commit4ba080a23da22c03aeeb7dea774d6a7060743823 (patch)
tree766b962f9f19e1ef65fceb18c1ffe90c09c434d4 /gnu/packages/golang-web.scm
parentd78e91a469e56ede20d2d281b9dffda2ecdf9347 (diff)
gnu: Add go-github-com-pion-ice.
* gnu/packages/golang-web.scm (go-github-com-pion-ice): New variable. Change-Id: Ia38d816c6ba8754faaf649b298cb43832c30de12 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 058018f0aa..d91749c851 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1647,6 +1647,55 @@ in Golang.")
go-golang-org-x-crypto
go-golang-org-x-net))))
+(define-public go-github-com-pion-ice
+ (package
+ (name "go-github-com-pion-ice")
+ (version "0.7.18")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/ice/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17108z4fkr9b2fxf5icxspgif29a40gi57bhp9a50mlfr36yv9vk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Source-only package
+ #:tests? #f
+ #:import-path "https://github.com/pion/ice"
+ #:phases
+ ;; Failed to build and only requried for inheritance:
+ ;;
+ ;; cannot use a.net (type *vnet.Net) as type transport.Net in field value:
+ ;; *vnet.Net does not implement transport.Net (wrong type for CreateDialer method)
+ ;; have CreateDialer(*net.Dialer) vnet.Dialer
+ ;; want CreateDialer(*net.Dialer) transport.Dialer
+ #~(modify-phases %standard-phases
+ (delete 'build))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-google-uuid
+ go-github-com-pion-dtls-v2
+ go-github-com-pion-logging
+ go-github-com-pion-mdns
+ go-github-com-pion-randutil
+ go-github-com-pion-stun
+ go-github-com-pion-transport
+ go-github-com-pion-turn-v2
+ go-golang-org-x-net))
+ (home-page "https://github.com/pion/ice/")
+ (synopsis "Go implementation of ICE")
+ (description
+ "This package provides an implementation of @acronym{ICE, Interactive
+Connectivity Establishment protocol}, specified in
+@url{https://datatracker.ietf.org/doc/html/rfc8445, RFC8445}. It is used as a
+part of @url{https://github.com/pion, Pion} WebRTC implementation.")
+ (license license:expat)))
+
(define-public go-github-com-pion-mdns
(package
(name "go-github-com-pion-mdns")