summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:27:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:35:38 +0100
commit51b0244afe0cb13d43c0479644030e98285fa761 (patch)
tree8b6e657e2d33f938875c0323b7845c7d85f58ed7 /gnu/packages/golang-web.scm
parent915209cb7e968df8d4144d24ce97af9a70232d26 (diff)
gnu: go-github-com-jackpal-gateway: Update to 1.0.15.
* gnu/packages/golang-web.scm (go-github-com-jackpal-gateway): Update to 1.0.15. [propagated-inputs]: Add go-golang-org-x-net. [native-inputs]: Add go-github-com-stretchr-testify. Change-Id: Ifcedc02b76d11dc215a904563aa6571aa52cedc3
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 36bf7fe0cd..22113f83fb 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1281,7 +1281,7 @@ JSON data to the machine.")
(define-public go-github-com-jackpal-gateway
(package
(name "go-github-com-jackpal-gateway")
- (version "1.0.6")
+ (version "1.0.15")
(source
(origin
(method git-fetch)
@@ -1290,15 +1290,21 @@ JSON data to the machine.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1yms2dw4dnz4cvj9vhwh6193d50jhvn5awsp2g3a4lcc3sjrgd6m"))))
+ (base32 "0dlspnbdz63b3kpavibd2764hdy53mx1v3vrqi721dsjy77r9ig3"))))
(build-system go-build-system)
(arguments
(list
+ #:go go-1.21
#:import-path "github.com/jackpal/gateway"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-net))
(home-page "https://github.com/jackpal/gateway")
(synopsis "Discover the address of a LAN gateway")
- (description "@code{gateway} is a Go library for discovering the IP
-address of the default LAN gateway.")
+ (description
+ "@code{gateway} is a Go library for discovering the IP address of the
+default LAN gateway.")
(license license:bsd-3)))
(define-public go-github-com-jackpal-go-nat-pmp