summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 22:35:12 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 23:18:47 +0100
commit74b2a9d5a41b6f8db3691e0f52660c3d18d32fe6 (patch)
tree15a1a604139b95181709da22f15019b8de8ef834 /gnu/packages/golang-web.scm
parent072b06f2f3751b493c8401b666a71618f3e937e6 (diff)
gnu: go-git-sr-ht-emersion-gqlclient: Move to golang-web.
* gnu/packages/golang.scm (go-git-sr-ht-emersion-gqlclient): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I2b07dc198f6710680da0430e5f302893060e37b8
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f7de466619..0d819eed3c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -16,18 +16,20 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Adam Kandur <kefironpremise@gmail.com>
+;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Filip Lajszczak <filip@lajszczak.dev>
;;; Copyright © 2023 Fries <fries1234@protonmail.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
-;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -103,6 +105,28 @@
API service accounts for Go.")
(license license:asl2.0)))
+(define-public go-git-sr-ht-emersion-gqlclient
+ (package
+ (name "go-git-sr-ht-emersion-gqlclient")
+ (version "0.0.0-20230820050442-8873fe0204b9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~emersion/gqlclient")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x64kcryawdr0daq1w6fada60zqrddw75yi397835b9ij7wb5gmh"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~emersion/gqlclient"))
+ (home-page "https://git.sr.ht/~emersion/gqlclient")
+ (synopsis "GraphQL client and code generator")
+ (description
+ "This package provides a GraphQL client and code generator for Go.")
+ (license license:expat)))
+
(define-public go-github-com-alexliesenfeld-health
(package
(name "go-github-com-alexliesenfeld-health")