summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-24 10:40:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:30 +0000
commita28498d83d644d02a0e02ce74954c6e936ff0543 (patch)
treedd0635eb2326833fd0ac6ce15e27ffb5eb983831 /gnu/packages/golang-web.scm
parentdda217f25ac3358b19542deb616756859df7225a (diff)
gnu: Add go-github-com-ugorji-go-codec.
* gnu/packages/golang-web.scm (go-github-com-ugorji-go-codec): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 4f2c6f8c1a..5f5278e11c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1394,6 +1394,38 @@ an interface to implement any other minifier.")
sockets.")
(license license:expat))))
+(define-public go-github-com-ugorji-go-codec
+ (package
+ (name "go-github-com-ugorji-go-codec")
+ (version "1.2.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ugorji/go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11j0sd7kli2bh2npfr2znnvdjsk118rs8khqzfdp6pb5jm0l20ib"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ugorji/go/codec"
+ #:unpack-path "github.com/ugorji/go"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively (string-append "src/"
+ import-path
+ "/bench")))))))
+ (propagated-inputs (list go-golang-org-x-tools))
+ (home-page "https://github.com/ugorji/go")
+ (synopsis "Codec and encoding library for various serialization formats")
+ (description
+ "This package provides a high performance and feature rich codec and
+encoding library for the MessagePack, CBOR, JSON and the Binc formats.")
+ (license license:expat)))
+
(define-public go-github-com-valyala-fasthttp
(package
(name "go-github-com-valyala-fasthttp")