summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 14:46:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:26 +0100
commitbe7386e288589f656658a109c73f4c37b4bddbff (patch)
tree699f62ea6ec20db19ba07c9d35dd9a179dabd21c /gnu/packages/golang-web.scm
parent3a94f439b39f3f4e11dd8feeb77bfc4e35d4735d (diff)
gnu: go-github-com-oschwald-geoip2-golang: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-oschwald-geoip2-golang): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: Ie95d3630ec98cd2f60139914959a82dc3313ea05
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0b4970f5d5..efbe3dd568 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1829,6 +1829,33 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-oschwald-geoip2-golang
+ (package
+ (name "go-github-com-oschwald-geoip2-golang")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oschwald/geoip2-golang")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jj4rbdpy87rbl79czg5hs5dyn6xlbnk0bnvyzi71dsxan57nixw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ; Requires some unpackaged software and test data
+ #:import-path "github.com/oschwald/geoip2-golang"))
+ (propagated-inputs
+ (list go-github-com-oschwald-maxminddb-golang))
+ (home-page "https://github.com/oschwald/geoip2-golang")
+ (synopsis "MaxMind GeoIP2 reader")
+ (description
+ "This package provides a library for reading MaxMind GeoLite2 and GeoIP2
+databases in Go.")
+ (license license:isc)))
+
(define-public go-github-com-oschwald-maxminddb-golang
(package
(name "go-github-com-oschwald-maxminddb-golang")