summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:57 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:16 -0500
commitc058e08d8b9cb6880c7485615e92623dc349fb33 (patch)
treefbc1911c1b7a1a98ecf199e08b9cc17ba926c2f8 /gnu/packages/golang-web.scm
parentdb6f2a0f8aa03110ae6d6179610f3e277110f1ab (diff)
gnu: go-github-com-jcmturner-goidentity-v6: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-jcmturner-goidentity-v6): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ibd9202efe7fc1002bc34376107a0e88872c888be
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 6a832291ab..751eb41b58 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -314,6 +314,30 @@ selection based on their relative weighting. This package is useful for
network applications that require accessing services using SRV records.")
(license license:asl2.0)))
+(define-public go-github-com-jcmturner-goidentity-v6
+ (package
+ (name "go-github-com-jcmturner-goidentity-v6")
+ (version "6.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcmturner/goidentity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "064ysvxvrvij843s7qj1nkzl5qc6j1qbrsb3s0zmwd1sa7vq8q1n"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jcmturner/goidentity/v6"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify go-github-com-hashicorp-go-uuid))
+ (home-page "https://github.com/jcmturner/goidentity")
+ (synopsis "Hold authenticated identities and their attributes")
+ (description "This package provides a standard interface for holding
+authenticated identities and their attributes.")
+ (license license:asl2.0)))
+
(define-public go-github-com-jcmturner-gokrb5-v8
(package
(name "go-github-com-jcmturner-gokrb5-v8")