summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:17 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:20 -0500
commitd087261febf44b44936548849f155bc57680dadb (patch)
treeedbcf0751ebaf81309c8e2b49f309c5040006e4b /gnu/packages/golang-web.scm
parent7a9f0869d4677b553083f6439b673b95beae766c (diff)
gnu: go-github-com-francoispqt-gojay: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-francoispqt-gojay): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I2ff041a91e2d37d79495a3ebda1b602784161c4a
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d021be005f..2790e2b5aa 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5,9 +5,9 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
@@ -310,6 +310,31 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+(define-public go-github-com-francoispqt-gojay
+ (package
+ (name "go-github-com-francoispqt-gojay")
+ (version "1.2.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/francoispqt/gojay")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ix95qdyajfmxhf9y52vjrih63f181pjs4v5as8905s4d5vmkd06"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/francoispqt/gojay"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify))
+ (synopsis "JSON encoder/decoder with powerful stream API for Golang")
+ (description "GoJay is a performant JSON encoder/decoder for Golang. It has
+a simple API and doesn't use reflection. It relies on small interfaces to
+decode/encode structures and slices.")
+ (home-page "https://github.com/francoispqt/gojay")
+ (license license:expat)))
+
(define-public go-github-com-go-chi-chi-v5
(package
(name "go-github-com-go-chi-chi-v5")