summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:41 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:13 -0500
commitd17d7e6ca1b4517162049dfa7f163b0ab0f737fd (patch)
tree4cace8dbb5f7c29a02c0864b435eea2f94409f1a /gnu/packages/golang-web.scm
parenta0006c4dc5354c703c74b7561a3e7866297e95dd (diff)
gnu: go-github-com-gorilla-css: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-css): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/configuration-management.sc: Add (gnu packages golang-web) module. * gnu/packages/golang.scm: As above... Change-Id: I6e387966d05c40321b9116b93d76fce68aad8c7f
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c779600411..1d61a76268 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,28 @@
;;;
;;; Code:
+(define-public go-github-com-gorilla-css
+ (package
+ (name "go-github-com-gorilla-css")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/css")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "116fhy3n7bsq3psyn4pa0i4x9zy916kh1zxslmbbp0p9l4i7ysrj"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gorilla/css/scanner"
+ #:unpack-path "github.com/gorilla/css"))
+ (home-page "https://github.com/gorilla/css/")
+ (synopsis "CSS3 tokenizer")
+ (description "This package provides a CSS3 tokenizer.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gorilla-mux
(package
(name "go-github-com-gorilla-mux")