summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-24 10:03:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:30 +0000
commite1a0562dae8b723cfb6c123c2c22f58b76da6a14 (patch)
tree3fb3d787f6e7c83270248849d02ebc0c8b4fb75f /gnu/packages/golang-web.scm
parent48b8655667f46d9418f897d4066a502c57738ff0 (diff)
gnu: Add go-github-com-pkg-sftp.
* gnu/packages/golang-web.scm (go-github-com-pkg-sftp): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5f5278e11c..1d7ad01af2 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1216,6 +1216,34 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-pkg-sftp
+ (package
+ (name "go-github-com-pkg-sftp")
+ (version "1.13.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/sftp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n35lzfrnrffjqy34ny6gxs27kq81s67ply6q8s1g19mhfzm6my7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pkg/sftp"))
+ (propagated-inputs (list go-golang-org-x-crypto go-github-com-kr-fs))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/pkg/sftp")
+ (synopsis "SFTP implementation for Go")
+ (description
+ "This package provides an @acronym{SFTP, SSH File Transfer Protocol}
+implementation, as described in
+@url{https://filezilla-project.org/specs/draft-ietf-secsh-filexfer-02.txt},
+for Go.")
+ (license license:bsd-2)))
+
(define-public go-github-com-pquerna-cachecontrol
(package
(name "go-github-com-pquerna-cachecontrol")