summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:53 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:33 +0000
commit10ecec291eac4a7d762fbb527734e9bf5fa9be85 (patch)
treef318c2ad1dfc08cc301bac08433730926b440f82 /gnu/packages/golang-xyz.scm
parent701907fae9782e038cd949ed4d8c8d1581d58ac2 (diff)
gnu: Add go-github-com-elliotchance-orderedmap.
* gnu/packages/golang-xyz.scm (go-github-com-elliotchance-orderedmap): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I44518a6a5371e5312b472aaa2c8d9a417d621924
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cbb7c394d8..d2e58001cf 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -462,6 +462,31 @@ Mark} detection.")
atimes for files.")
(license license:expat)))
+(define-public go-github-com-elliotchance-orderedmap
+ (package
+ (name "go-github-com-elliotchance-orderedmap")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elliotchance/orderedmap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06gq5hsgfmzfr46wds366ghyn16qkygyz83vrsgargf4l7db9zg7"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/elliotchance/orderedmap"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/elliotchance/orderedmap")
+ (synopsis "Go ordered map library")
+ (description
+ "This package provides a ordered map library that maintains amortized O(1)
+for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
+ (license license:expat)))
+
(define-public go-github-com-gabriel-vasile-mimetype
(package
(name "go-github-com-gabriel-vasile-mimetype")