summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 22:25:00 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 22:59:13 +0000
commit30afb17152462e180b92b06829ab85d0a2d337cf (patch)
tree065e2a9f323c9290ee69e21882667a63d51af817 /gnu/packages/golang-xyz.scm
parent592b14483695decd45d0784ec14debd062b48664 (diff)
gnu: Add go-github-com-coreos-go-systemd-daemon.
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-daemon): New variable. Change-Id: If79215d0676b9bb8dfe6e12a144a9b156f43f9be Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5673324fc5..210d9d72fa 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -231,6 +231,18 @@ similar to Go's standard library @code{json} and @code{xml} package.")
using socket activation from Go.")
(license license:asl2.0)))
+(define-public go-github-com-coreos-go-systemd-daemon
+ (package
+ (inherit go-github-com-coreos-go-systemd-activation)
+ (name "go-github-com-coreos-go-systemd-daemon")
+ (arguments
+ '(#:import-path "github.com/coreos/go-systemd/daemon"
+ #:unpack-path "github.com/coreos/go-systemd"))
+ (home-page "https://github.com/coreos/go-systemd")
+ (synopsis "Go bindings to systemd for notifications")
+ (description "Go bindings to systemd for notifying the daemon of service
+status changes")))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")