summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 22:43:37 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 22:59:14 +0000
commit40cc2ca588607f976f0adc094b91a886ef0044f6 (patch)
treec0ee001265d0dc361966a48bce57ee9adb05b1b5 /gnu/packages/golang-xyz.scm
parentba17880abd18b59eaf41e04893ce019cb1724814 (diff)
gnu: Add go-github-com-coreos-go-systemd-login1.
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-login1): New variable. Change-Id: I815e67c119b00232a620004f72e6b61d90d2c06a Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2bb68ecb86..909442a762 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -270,6 +270,20 @@ running services and units.")))
(description "Go bindings to systemd for writing to systemd's logging
service, journald.")))
+(define-public go-github-com-coreos-go-systemd-login1
+ (package
+ (inherit go-github-com-coreos-go-systemd-activation)
+ (name "go-github-com-coreos-go-systemd-login1")
+ (arguments
+ '(#:tests? #f ;Tests require D-Bus daemon running.
+ #:import-path "github.com/coreos/go-systemd/login1"
+ #:unpack-path "github.com/coreos/go-systemd"))
+ (native-inputs (list go-github-com-godbus-dbus))
+ (home-page "https://github.com/coreos/go-systemd")
+ (synopsis "Go bindings to systemd for integration with logind API")
+ (description "Go bindings to systemd for integration with the systemd
+logind API.")))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")