summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-24 21:49:35 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-24 21:49:35 +0000
commit40d697a30140321865f2c3fff28711d543673474 (patch)
treec2e1863d847aeb9d59c8e97af562e217a0919da5 /gnu/packages/golang-xyz.scm
parentdb340ca57a7991b0b2c8c4c5f5c28e218b2ad700 (diff)
gnu: go-github-com-lib-pq: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-lib-pq): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/databases.scm: Remvoe (gnu packages syncthing). Change-Id: I0f2f9c2366fd47b7167044d76f8c2c67a2f65544
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 65de42f642..6c08e74104 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
@@ -1221,6 +1222,33 @@ called concurrently with themselves and each other.")
customized globally.")
(license license:expat)))
+(define-public go-github-com-lib-pq
+ (package
+ (name "go-github-com-lib-pq")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lib/pq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08j1smm6rassdssdks4yh9aspa1dv1g5nvwimmknspvhx8a7waqz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/lib/pq"
+ ;; The tests seem to fail without access to the network or a running
+ ;; Postgres instance.
+ #:tests? #f))
+ (home-page "https://github.com/lib/pq")
+ (synopsis "Golang Postgres driver for Go's database/sql")
+ (description
+ "This package provides a pure Go Postgres driver for Go's
+database/sql package.")
+ (license license:expat)))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")