summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:03:39 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:31 +0000
commit5f5d8167b19e21146b56299c44117fd1a6509eba (patch)
tree68788fbbe0d34b465d7f1e8c1eabcf74f3df9317 /gnu/packages/golang-xyz.scm
parente6ce91d1bf610baba201d9d81557d79baa15ccd8 (diff)
gnu: go-github-com-hashicorp-go-uuid: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-hashicorp-go-uuid): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ib97abb60b716c971bb54144d7d1ea015211e1ed4
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 05f32ad2e4..c6c1c4bb24 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
@@ -844,6 +845,32 @@ standardized approach for introspecting on error values.")
"This package is a very simple wrapper around log/syslog")
(license license:expat)))
+(define-public go-github-com-hashicorp-go-uuid
+ (package
+ (name "go-github-com-hashicorp-go-uuid")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-uuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wd4maaq20alxwcvfhr52rzfnwwpmc2a698ihyr0vfns2sl7gkzk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-uuid"))
+ (home-page "https://github.com/hashicorp/go-uuid")
+ (synopsis "Generate UUID-format strings")
+ (description
+ "This package generates UUID-format strings using high quality bytes.
+It is not intended to be RFC compliant, merely to use a well-understood string
+representation of a 128-bit value. It can also parse UUID-format strings into
+their component bytes.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")