summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-23 00:14:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:28 +0000
commit8468c5556577e36f566c39ae74835bebfa900930 (patch)
tree905ce81d6cc4a8d405c9ebdab8649e94618a5e6e /gnu/packages/golang-xyz.scm
parent51a10d33166a33cf25fd22397382a5684ccf003e (diff)
gnu: go-github-com-shirou-gopsutil: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-shirou-gopsutil): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 90942f8991..09b20a4830 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2,7 +2,8 @@
;;; Copyright © 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
-;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
@@ -1093,6 +1094,31 @@ Metrics library.")
(home-page "https://github.com/rcrowley/go-metrics")
(license license:bsd-2))))
+(define-public go-github-com-shirou-gopsutil
+ (let ((commit "47ef3260b6bf6ead847e7c8fc4101b33c365e399")
+ (revision "0"))
+ (package
+ (name "go-github-com-shirou-gopsutil")
+ (version (git-version "v2.19.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit commit))) ; XXX
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x1g4r32q4201nr2b754xnrrndmwsrhfr7zg37spya86qrmijnws"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/shirou/gopsutil"))
+ (synopsis "Process and system monitoring in Go")
+ (description "This package provides a library for retrieving information
+on running processes and system utilization (CPU, memory, disks, network,
+sensors).")
+ (home-page "https://github.com/shirou/gopsutil")
+ (license license:bsd-3))))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")