summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:51 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:33 +0000
commitb2ad18ce4d966ca7c12d7d9ca49556f5e88568b6 (patch)
tree8bcef2c92653f9ebda5538d73befa7ce077397a2 /gnu/packages/golang-xyz.scm
parentfd28001a44e725b4da2d29b7eae130d30db5db88 (diff)
gnu: Add go-github-com-alecthomas-participle-v2.
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-participle-v2): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ia6a75894a65de756b771d2467125db411da2708b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5312198009..8df9481b0e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -74,6 +74,34 @@
substitution.")
(license license:expat)))
+(define-public go-github-com-alecthomas-participle-v2
+ (package
+ (name "go-github-com-alecthomas-participle-v2")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/participle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k2vsd58rgwyylyn5zja6z6k1sg4m39g2fhd88lvja60ca51bh98"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:go go-1.18
+ #:import-path "github.com/alecthomas/participle/v2"))
+ (native-inputs
+ (list go-github-com-alecthomas-assert-v2))
+ (home-page "https://github.com/alecthomas/participle")
+ (synopsis "Parser library for Go")
+ (description
+ "This package provides a parser library for Golang which constructs
+parsers from definitions in struct tags and parses directly into those
+structs. The approach is similar to how other marshallers work in Golang,
+\"unmarshalling\" an instance of a grammar into a struct.")
+ (license license:expat)))
+
(define-public go-github-com-anmitsu-go-shlex
(package
(name "go-github-com-anmitsu-go-shlex")