summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 15:17:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commitee79286031e87fc7f2e5477a56a9c49b74971080 (patch)
tree1c704d626817b6b1f6a37d8e8b592d1648eeef2e /gnu/packages/golang-xyz.scm
parent930692feb0d26c2d9ab5715a2a84196eef13f221 (diff)
gnu: go-github-com-alecthomas-chroma: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-alecthomas-chroma): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/configuration-management.scm: Add (gnu packages golang-xyz) module. Change-Id: I0f5f7068f530b282f3636678e9edc4fad6c8c94a
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d6aa5d0538..a31cd74b3d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3,15 +3,16 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
-;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -79,6 +80,36 @@
substitution.")
(license license:expat)))
+(define-public go-github-com-alecthomas-chroma
+ (package
+ (name "go-github-com-alecthomas-chroma")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/chroma")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "066a6rdmf670d3v5sc7chbn7db09ldgxjympb03pcqwk644dixb1"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/alecthomas/chroma"))
+ (native-inputs
+ (list go-github-com-dlclark-regexp2
+ go-github-com-alecthomas-assert
+ go-github-com-alecthomas-colour
+ go-github-com-alecthomas-repr
+ go-github-com-mattn-go-isatty
+ go-github-com-sergi-go-diff))
+ (home-page "https://github.com/alecthomas/chroma/")
+ (synopsis "General purpose syntax highlighter in pure Go")
+ (description
+ "Chroma takes source code and other structured text and converts it into
+syntax highlighted HTML, ANSI-coloured text, etc.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-participle-v2
(package
(name "go-github-com-alecthomas-participle-v2")