summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 00:35:59 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:33 +0000
commitefa4809384e4b82395818431b1d37a0dbfe89ba5 (patch)
treef21dea03981ed7eebfba00f444b27444608bde46 /gnu/packages/golang-xyz.scm
parentdca16f4e1fcfc66101d312707d856205377703fa (diff)
gnu: go-github-com-songmu-gitconfig: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-songmu-gitconfig): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/version-control.scm: Add (gnu packages golang-xyx) module. Change-Id: Ibab2595d981d46096501bb8ab495e899d2aacf7d
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 32b9be40b6..ff62b83995 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -1136,6 +1137,33 @@ efficiently works with standard packages like @code{io}, @code{bufio}, etc..
Use waterutil with it to work with TUN/TAP packets/frames.")
(license license:bsd-3)))
+(define-public go-github-com-songmu-gitconfig
+ (package
+ (name "go-github-com-songmu-gitconfig")
+ (version "0.1.0")
+ (home-page "https://github.com/songmu/gitconfig")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y01h496a7pfj1g2bclls5b0nl3vnj7nz610jj1dzq9kxrwxk7fk"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/Songmu/gitconfig"
+ ;; Package's tests appear to be hardcoded to the author's gitconfig
+ ;; and require network access.
+ #:tests? #f))
+ (propagated-inputs
+ (list go-github-com-goccy-yaml))
+ (synopsis "Go library to get configuration values from gitconfig")
+ (description
+ "@{gitconfig} is a package to get configuration values from gitconfig.")
+ (license license:expat)))
+
(define-public go-github-com-stathat-go
(let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
(revision "0"))