summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:12:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:37:51 +0000
commitf3914c1a7bee3f552d2ce653f7fb8ac07829063a (patch)
tree8636175bee45409afd4bacbac4f81b8f47c55d87 /gnu/packages/golang-xyz.scm
parent080f93132064eb16df0ea1d7d744975193c2a9de (diff)
gnu: go-github-com-hashicorp-go-version: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-hashicorp-go-version): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ica0c069e90ade97efbbb201f36d92ff70bad1c8b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c6c1c4bb24..27216e745d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -871,6 +871,35 @@ representation of a 128-bit value. It can also parse UUID-format strings into
their component bytes.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-version
+ (let ((commit
+ "03c5bf6be031b6dd45afec16b1cf94fc8938bc77")
+ (revision "0"))
+ (package
+ (name "go-github-com-hashicorp-go-version")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-version")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sjq57gpfznaqdrbyb2p0bn90g9h661cvr0jrk6ngags4pbw14ik"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/go-version"))
+ (home-page "https://github.com/hashicorp/go-version")
+ (synopsis "Go library for parsing and verifying versions and version
+constraints")
+ (description
+ "This package is a library for parsing versions and version
+constraints, and verifying versions against a set of constraints. It can sort
+a collection of versions properly, handles prerelease/beta versions, can
+increment versions.")
+ (license license:mpl2.0))))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")