summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:41 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:18 -0400
commit01c974855598e0a7ead38639d1be73b3244f4ec2 (patch)
tree9bfdc81671bf5c419b76c6a39382b080e9a7ac7f /gnu/packages/golang.scm
parent8c64e40266168af94d7f75b2563189d72f9b4b46 (diff)
gnu: Add go-github-com-leonelquinteros-gotext.
* gnu/packages/golang.scm (go-github-com-leonelquinteros-gotext): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 059b67cb90..c5103b9cc9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1673,6 +1673,42 @@ terminals.")
aid data snapshotting.")
(license license:isc)))
+(define-public go-github-com-leonelquinteros-gotext
+ (package
+ (name "go-github-com-leonelquinteros-gotext")
+ (version "1.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/leonelquinteros/gotext")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15zjc7s1p29izagc84andzhnxw17763rax31jqvf9r5fzvlm0ccn"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/leonelquinteros/gotext"))
+ (propagated-inputs (list go-golang-org-x-tools go-golang-org-x-text))
+ (home-page "https://github.com/leonelquinteros/gotext")
+ (synopsis "GNU gettext utilities in Go")
+ (description "This package implements GNU gettext utilities in Go. It features:
+@itemize
+@item Implements GNU gettext support in native Go.
+@item Complete support for PO files including:
+@item Support for MO files.
+@item Thread-safe: This package is safe for concurrent use across multiple
+goroutines.
+@item It works with UTF-8 encoding as it's the default for Go language.
+@item Unit tests available.
+@item Language codes are automatically simplified from the form en_UK to en if
+the first isn't available.
+@item Ready to use inside Go templates.
+@item Objects are serializable to []byte to store them in cache.
+@item Support for Go Modules.
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-pkg-xattr
(package
(name "go-github-com-pkg-xattr")